WebSpellChecker.net Wiki

System Requirements (WSC Application 4.8.8+)

Note: The system requirements described below are for WSC application starting version 4.8.8 and higher.

For all previous versions of WSC application, please refer to the following requirements.

Server Hardware Requirements

The WebSpellChecker application can be installed on any server which has modern hardware.

Also, it may be installed and configured on any cloud service providers like Amazon Web Services (AWS) choosing one of the Amazon EC2 instances.

  • Minimal instance (General Purpose): t2.medium

Hardware: Variable ECUs, 2 vCPUs, 2.5 GHz, Intel Xeon Family, 4 GB memory, EBS only

  • Suggested instance (Compute Optimized): c3.large

Hardware: c3.large (7 ECUs, 2 vCPUs, 2.8 GHz, Intel Xeon E5-2680v2, 3.75 GB memory, 2 x 16 GB Storage Capacity)

Platforms

The WebSpellChecker application can be installed and run on servers with Windows and Linux-based platforms (x64):

Windows Server:

  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016

Linux Distributives:

  • Ubuntu Server with LTS 12.04+
  • CentOS 6.0+
  • Red Hat Enterprise Linux (RHEL) 6.0+

Web Server or Application Server

The WebSpellChecker application server requires configuration of a CGI-capable web-server with enabled CGI handler or application server.

Web Server Application Server
Internet Information Services (IIS) 7.0+ Apache Tomcat 7.0+
Apache HTTP Server 2.2+ Oracle WebLogic Server 11g (10.3.6), 12c (12.2.1+)

Supported Browsers

Below listed the web browsers that are supported by the WebSpellChecker application. Both SpellCheckAsYouType (SCAYT) and WebSpellChecker (WSC) products work as intended in default (strict) mode only, thus any compatibility modes are not supported.

ProductChromeFirefoxSafariEDGEIE11IE10IE9IE8
SCAYT for CKEditor 4.0+supportedsupportedsupportedsupportedsupportedsupportedsupportedsupported
WSC for CKEditor 4.0+supportedsupportedsupportedsupportedsupportedsupportedsupportedsupported
SCAYT for TinyMCE 4.0+supportedsupportedsupportedsupportedsupportedsupportedsupportedsupported
WSC for TinyMCE 4.0+supportedsupportedlimitedlimitedsupportedsupportedsupportedsupported
WSC for Editable Controlssupportedsupportedlimitedlimitedsupportedsupportedsupportedsupported
SCAYT for Editable Controlssupportedsupportedsupportedsupportedsupportedlimitedlimitedlimited
SCAYT for Froala Editorsupportedsupportedsupportedsupportedsupportedlimitedlimitedlimited

*limited means that the main functionality works properly but any development, fixes and enhancements are not planned for mentioned versions of products.

Feel free to post any comments or suggestions to Technical support.